{//% unless portal.user.is_agent %} Tickets
Welcome
Login Submit a Ticket {//% endunless %}

Old browsers not supported: “this connection is not secure”

Old browsers not supported for our support portal

Our Support portal provider informed us that starting 01-October 2021 old browsers will not be supported any more


Who will be affected?

Users who have not updated their browsers and programmable frameworks (including OpenSSL (1.0.2)) after 2018. 



What will be the impact?

Users and their end customers on outdated browser versions will see the page that reads “this connection is not secure” or a similar security-related alert that prevents them from accessing the page. 

Below is a list of OS and web clients that will be affected:

  • OpenSSL <= 1.0.2
  • Windows < XP SP3 (assuming Automatic Root Certificate Update isn’t manually disabled)
  • macOS < 10.12.1 (year 2016)
  • iOS < 10 (iPhone 5 is the lowest model that can get to iOS 10)
  • Android < 7.1.1 (but >= 2.3.6 will work if served ISRG Root X1 cross-sign)
  • Mozilla Firefox < 50
  • Ubuntu < 16.04
  • Debian < 8
  • Java 8 < 8u141
  • Java 7 < 7u151
  • NSS < 3.26
  • Amazon FireOS (Silk Browser)
  • How to know if this will affect you?

Open this link on your browser by clicking HERE. If the page loads fine and show as below, your OS and web client support the root certificate, and there is no further action required.


If you are impacted 

Please contact your IT to help you upgrade to the right requirements.

Did you find it helpful? Yes No

Send feedback
Sorry we couldn't be helpful. Help us improve this article with your feedback.